[Logiciel] Admin Tool Radius

Après mon premier outil Admin Tool VPN permettant une gestion avancée du VPN de Mountain Lion Server, je vous annonce aujourd’hui la publication sur le Mac App Store de ma nouvelle application de cette suite d’outil perso, Admin Tool Radius.

Le but de cette application est d’exposer les réglages du serveur Radius de Mountain Lion Server. Le Radius est entre autres nécessaire lorsque vous souhaitez qu’un service externe (borne d’accès WPA2 Entreprise, concentrateur VPN, swtich sécurisé avec 802.1x…) utilise les identités de votre OpenDirectory comme base d’authentification.

Capture d’écran 2013-04-19 à 20.37.27

Ce nouvel outil est disponible dès aujourd’hui sur le Mac App Store au prix de 1,79 €.

3 réflexions au sujet de « [Logiciel] Admin Tool Radius »

  1. Bonjour Yoan
    Merci pour ton appui. Je voudrais m’en servir pour migrer un serveur 10.7 qui utilise Radius vers 10.8 ou 10.9 (je n’arrive pas à me décider)
    Quand je le lance sur le 10.7 ( cela à déjà marché) j’ai la fenêtre qui ne s’ouvre pas et ces messages:
    12/11/13 02:44:26,409 Admin Tool Radius: Error loading /Applications/Admin Tool Radius.app/Contents/PlugIns/Radius.bundle/Contents/MacOS/Radius: dlopen(/Applications/Admin Tool Radius.app/Contents/PlugIns/Radius.bundle/Contents/MacOS/Radius, 265): Symbol not found: _OBJC_METACLASS_$_NSObject
    Referenced from: /Applications/Admin Tool Radius.app/Contents/PlugIns/Radius.bundle/Contents/MacOS/Radius
    Expected in: /usr/lib/libobjc.A.dylib
    in /Applications/Admin Tool Radius.app/Contents/PlugIns/Radius.bundle/Contents/MacOS/Radius
    12/11/13 02:44:26,460 Admin Tool Radius: Controller cannot be nil
    12/11/13 02:44:31,232 Admin Tool Radius: -[NSPersistentUIManager snapshotWindow:handler:]: CGSCaptureWindowsContentsToRectWithOptions(cid, &wid, 1, CGRectZero, kCGSWindowCaptureBestResolution, &image) returned error 1000 on line 2431

    Quand au 10.9, est-il compatible? Car quand je configure une borne j’ai ce message:
    12/11/2013 02:46:58,667 Admin Tool Radius[4342]: SecOSStatusWith error:[-34018] The operation couldn’t be completed. (OSStatus error -34018 – Remote error : The operation couldn‚Äôt be completed. (OSStatus error -34018 – client has neither application-identifier nor keychain-access-groups entitlements))

    Merci d’avance
    Cordialement.
    Olivier

    • Concernant 10.7, j’ai pu reproduire le problème ici, ce qui m’étonne c’est qu’il fonctionnait jusqu’à présent et qu’il n’y a eu ni mise à jour de 10.7, ni mise à jour de mon application…

      À propos de 10.9. Ici cela fonctionne sans soucis. Essayez de réinstaller l’application pour voir.

      En attendant d’avoir ciblé les problèmes, vous pouvez toujours lancer l’outil depuis un système fonctionnel (10.8 ?) et vous connecter à distance sur un serveur de version différente.

Laisser un commentaire